首页 » Linux » 树莓派使用gnuplot时报错

树莓派使用gnuplot时报错

使用gnuplot时无法使用鼠标进行操作并且报错:

libEGL warning: DRI3: failed to query the version
libEGL warning: DRI2: failed to authenticate
QXcbConnection: XCB error: 1 (BadRequest), sequence: 410, resource id: 273, major code: 155 (Unknown), minor code: 1
XmbTextListToTextProperty result code -2
XmbTextListToTextProperty result code -2
XmbTextListToTextProperty result code -2

原因是使用的是QT版本的gnuplot。不知道是QT的bug还是树莓派版本的QT不完整,所以出现该错误。

解决方法是使用如下代码安装X11版本的gnuplot,如果已经安装了QT版本会自动替换为X11版本。

sudo apt-get install gnuplot-x11

X11界面背景图标都不如QT,但是所有功能都可以使用了

gnuplot界面
标签:

发表评论

电子邮件地址不会被公开。 必填项已用*标注